Microsoft Teams Service Degradation

Incident Report for Action for Children

Resolved

This incident has been resolved.
Posted Feb 18, 2026 - 14:59 GMT

Investigating

Microsoft are currently reporting an issue with Microsoft Teams. This issue potentially impacts some users attempting to join affected meetings through the "Join" button.

While they work on resolving the issue, users can join meetings by opening the meeting invite in your calendar and scrolling down to the 'Join' link at the bottom of the meeting details.
Posted Feb 16, 2026 - 11:57 GMT
This incident affected: Office 365 (Microsoft Teams).